How can we improve OneNote Online?

Disable Auto-capitalization

On the Web App version, there doesn't seem to be a way to disable auto-caps. When I'm taking notes with code in it, it'll auto cap things like "var =" or "somekey: " in a JSON snippet. I like to make snippets I can copy-paste later, but if I'm entering the code on the Web App version, it mucks it up and I have to go back and uncap about every line. If I have it disabled on the Windows desktop version, why wasn't that designed to carry over as the default? If there's no dialog to change it, at least set it to what the full-blown desktop version has set.

146 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Brian Chandler shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Completed  ·  Adminshanlee (Admin, OneNote Team) responded  · 

We’ve recently added the ability to choose whether or not you want to auto-capitalize words. To disable auto-capitalization, go to Home>Spelling and select AutoCorrect Options. In the AutoCorrect Options pop-up, de-select the “Capitalize first letter of sentences” box. Re-select the box to re-enable auto-capitalization.

58 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    would like ability to set auto correct options like desktop option
    such as NOT correcting all-cap words -or such as CNA to CAN, where CNA is an acronym

  • Chris Kemp commented  ·   ·  Flag as inappropriate

    I absolutely love OneNote. It’s one of the best pieces of software I know. Amazing flexibility, but this auto-correct thing is driving me nuts. I’m using one-note to create and share screen designs, which include code/css snippets and there’s nothing I can seem to do to stop the first character being capitalised. The only workaround I’ve found is to double enter the first character, type the word in and then remove the double entered character. Even then the autocorrect will “correct” my typing.

  • Nima Ghorbani commented  ·   ·  Flag as inappropriate

    There should be an option to turn this off! lot of my notes are codes and it absolutly should not be first letter capitalized!!

  • Wes commented  ·   ·  Flag as inappropriate

    Exactly. When you're pasting code snippets in onenote web and then copying them into code on another machine this can REALLY ruin your day. Who cares about autocorrect in their rough notes anyway? Surely it should be an option not a default?

  • Anonymous commented  ·   ·  Flag as inappropriate

    Just make the OneNote dictionary actually obey the iOS dictionary. It’s incredibly frustrating and has me looking for another app to take my notes in...

  • Vincent Emery commented  ·   ·  Flag as inappropriate

    I do a lot of code and (used to) use this to make notes and list key commands. I've switched to another online note taking app now as the auto-capitalisation is dreadful. Won't be using OneNote again until this problem is solved.

  • Cole Eagland commented  ·   ·  Flag as inappropriate

    Adding my vote. I have to add time for "decapitalizing" into my daily workflow. And... I'm only kidding a little bit.

  • clemo commented  ·   ·  Flag as inappropriate

    And also after each abbreviation. I.e. When I use abbr. Like e.g. Jan., Feb., etc., the dot is always evaluated as period/full stop/end of sentence. Like T N said, as if we were idiots wo don't know when we mean to end a sentence.

  • Anonymous commented  ·   ·  Flag as inappropriate

    1.In OneNote Online, I can‘t disable auto-correction
    2.I want using some box in onenote which can typing code in it

Feedback and Knowledge Base